Aktualizacja z wersji 1.33 do 3.8

Wszystko na temat instalacji oprogramowania KQS.store oraz aktualizacji skryptu do najnowszej wersji. Dowiesz się także co nowego pojawiło się w sklepie KQS oraz znajdziesz pełną listę zmian które weszły w nowej wersji.

Aktualizacja z wersji 1.33 do 3.8

przez delta » 2014 lut 17, Pn 15:43

Witam.
Jakiś czas temu provider uaktualnił na serwerze wersję PHP do 5.5.5
Przed aktualizacją wersja sklepu działała, dodam, że była to wersja 1.33, natomiast po aktualizacji sklep przestał działać. Wyświetla się tylko pusta strona. Pomyślałem, że jest to wina starej wersji sklepu.
Odszukałem maile i znalazłem wersję 3.8 i zabrałem się za aktualizację. Nadpisałem wszystkie pliki na serwerze, lecz w dalszym ciągu wyświetla się pusta biała strona.
Sprawdziłem sobie wersję PHP zainstalowaną na serwerze razem z ionCube:

PHP 5.5.5 (cli) (built: Nov 29 2013 09:41:09)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
with the ionCube PHP Loader v4.5.0, Copyright (c) 2002-2013, by ionCube Ltd., and
with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies

Stwierdziłem, że wszystko w porządku, lecz dalej strona nie działała.

Poprosiłem więc o logi admina po wybraniu update.php w przeglądarce i oto wynik:
[Mon Feb 17 13:58:55 2014] [error] [client 91.XXX.XXX.34] PHP Fatal error: The file /usr/home/sklep/update.php was encoded by the ionCube Encoder for PHP 4 and cannot run under PHP 5.5.\n Please ask the provider of the script to provide a version encoded with either the ionCube Encoder for PHP 5.3 or for PHP 5.4. in Unknown on line 0

Nie mam pomysłu co dalej zrobić.
Proszę o pomoc.
 
Autor tematu
Posty: 4
Dołączył(a): 2014 sty 20, Pn 12:18
Podziękował : 0 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacja z wersji 1.33 do 3.8

przez marpit » 2014 lut 18, Wt 13:51

Zaktualizować ioncube ?
Avatar użytkownika
Moderator Witryny
 
Posty: 1691
Dołączył(a): 2008 maja 05, Pn 16:13
Podziękował : 0 razy
Otrzymał podziękowań: 1 razy

Re: Aktualizacja z wersji 1.33 do 3.8

przez CptSimonini » 2014 lut 18, Wt 20:30

Jeśli masz taką opcję to spróbuj downgrade'u swojego PHP do 5.4 z ionCube i bez Zend.
 
Posty: 64
Dołączył(a): 2009 paź 08, Cz 21:11
Podziękował : 0 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacja z wersji 1.33 do 3.8

przez delta » 2014 lut 25, Wt 11:57

Dostałem informację od administratora serwera, że nie ma takiej możliwości aby zrobić downgrade do niższej wersji. Podyktowane jest to tym, iż na tym serwerze jest bardzo dużo firm, którzy potrzebowały najnowszą wersję PHP.
Czy ktoś ma jeszcze jakiś pomysł, jak sobie z tym poradzić?
 
Autor tematu
Posty: 4
Dołączył(a): 2014 sty 20, Pn 12:18
Podziękował : 0 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacja z wersji 1.33 do 3.8

przez delta » 2014 mar 26, Śr 10:16

Niestety nie ma możliwości downgrad'u PHP :(
 
Autor tematu
Posty: 4
Dołączył(a): 2014 sty 20, Pn 12:18
Podziękował : 0 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacja z wersji 1.33 do 3.8

przez delta » 2014 maja 05, Pn 13:09

Zauważyłem że wyszła nowa wersja ionCube wydana 22 kwietnia br. Napisałem więc do admina aby zaktualizował wtyczkę. W odpowiedzi dostałem informacje:
"aktualizacja loadera po stronie serwera nic nie zmieni, jak już wcześniej wspominałem musicie się zgłosić do programistów w/w sklepu internetowego aby dostarczyli wam nową wersję pod PHP5 zakodowane nowym IonCube - aktualne pliki waszego sklepu sa zakodowane ionCube Encoder for PHP 4
a serwer posiada PHP 5.5 z nowym IonCube który nie potrafi zdekodować tego wcześniejszego."

Moje pytanie brzmi, czy autor tego sklepu czyta to forum i czy jest jakaś szansa aby zaktualizował sklep do wersji 5.5 z nowym ionCube?
 
Autor tematu
Posty: 4
Dołączył(a): 2014 sty 20, Pn 12:18
Podziękował : 0 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacja z wersji 1.33 do 3.8

przez lity » 2014 maja 05, Pn 15:22

delta napisał(a):Zauważyłem że wyszła nowa wersja ionCube wydana 22 kwietnia br. Napisałem więc do admina aby zaktualizował wtyczkę. W odpowiedzi dostałem informacje:


Przepraszam, ale dla mnie jest to bardzo dziwne, że provider sam sobie zmienia wersję PHP dla całego serwera i nie pozostawia alternatywy.
Miałem serwery w kilku firmach i ZAWSZE miałem wybór, co do wersji PHP.

Jeżeli masz możliwość, to zmień sobie providera, np: na Odnośnik widoczny tylko dla zalogowanych użytkowników - Zarejestruj się - sam z tego korzystam.

Tam sam, w panelu administracyjnym, możesz sobie zmienić wersję PHP na jaką chcesz - jednym kliknięciem myszki. I żeby była jasność, to piszę o hostingu, a nie o serwerze dedykowanym.

Sam kilka dni temu przeszedłem z wersji PHP 5.2 na wersję: Podstawowa wersja PHP 5.4 z zainstalowanym oprogramowaniem IonCube

Po 10 minutach serwer pracował już na nowej wersji PHP.

Można również samemu zrobić downgrade - jednym kliknięciem myszki.

Pozdrawiam

Paweł
 
Posty: 66
Dołączył(a): 2010 kwi 02, Pt 08:31
Podziękował : 0 razy
Otrzymał podziękowań: 2 razy


Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości
cron