Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

Wszystko na temat instalacji oprogramowania KQS.store oraz aktualizacji skryptu do najnowszej wersji. Dowiesz się także co nowego pojawiło się w sklepie KQS oraz znajdziesz pełną listę zmian które weszły w nowej wersji.

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez diversio » 2016 wrz 17, So 17:14

areczek napisał(a):
The file /index.php was encoded with the PHP 5.4 ionCube Encoder and requires PHP 5.4 to be installed

Powyższa linijka jest odpowiedzią ... 5.4 wymagane jest prze ionCube'a


No dobrze.
To w takim razie do jakiej wersji PHP przeznaczone jest (nie z którą działa - planowo czy przypadkowo) KQS.store_4.x i KQS.update_4.x ?
Avatar użytkownika
 
Autor tematu
Posty: 126
Dołączył(a): 2008 kwi 25, Pt 11:33
Lokalizacja: Wola Młocka, Mazowsze
Podziękował : 12 razy
Otrzymał podziękowań: 3 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez areczek » 2016 wrz 17, So 17:42

Plik aktualizacji update_4.3_php54 (paczka dla phpa 5.4) jest zabezpieczony ioncubem, który wymaga phpa w wersji 5.4 dlatego gdy ustawiłeś php 5.3 na serwerze wywaliło Ci błąd - tak jak wcześniej napisałem jak masz aplikację działającą/wykorzystującą elementy wprowadzone od PHP 5.4 to nie będzie działała na wcześniejszych wersjach PHPa - ionCube wykorzystuje nowe elementy PHP 5.4 i wymaga minimum php 5.4
Avatar użytkownika
 
Posty: 329
Dołączył(a): 2009 lip 07, Wt 18:33
Lokalizacja: Lubelskie
Podziękował : 0 razy
Otrzymał podziękowań: 10 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez diversio » 2016 wrz 17, So 17:50

areczek napisał(a):Plik aktualizacji update_4.3_php54 (paczka dla phpa 5.4) jest zabezpieczony ioncubem, który wymaga phpa w wersji 5.4 dlatego gdy ustawiłeś php 5.3 na serwerze wywaliło Ci błąd - tak jak wcześniej napisałem jak masz aplikację działającą/wykorzystującą elementy wprowadzone od PHP 5.4 to nie będzie działała na wcześniejszych wersjach PHPa - ionCube wykorzystuje nowe elementy PHP 5.4 i wymaga minimum php 5.4


Chyba przez przeoczenie nie zauważyłeś, że pytałem o coś innego - o pliki bez _php54

Krótko:
Czy pliki bez sufiksu _php54, są do wersji <5.4 i tylko przypadkowo działają jeszcze na wyższych wersjach PHP 5.4, 5.5, 5.6, czy też są do wszystkich wersji (tylko po co wtedy pliki z _php54, jeśli te bez sufiksu działają również na PHP 5.4.x i wyżej)
Czy ...
No właśnie sam nie wiem
Chodzi mi o wykluczenie domysłów, przypuszczeń, intuicji i "widzimisiów"

Może być też tak, że twórca oprogramowania miał zupełnie inny cel w tworzeniu dodatkowych paczek z _php54 (ionCube ???)
Avatar użytkownika
 
Autor tematu
Posty: 126
Dołączył(a): 2008 kwi 25, Pt 11:33
Lokalizacja: Wola Młocka, Mazowsze
Podziękował : 12 razy
Otrzymał podziękowań: 3 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez areczek » 2016 wrz 17, So 18:24

Wydaje mi się, że przyczyną wywalania błędów lub nie wywalania jest (wcześniej też to założyłem) z czego sklep był instalowany z której wersji czy dla 5.4 czy nie.

instalacja wykonana plikami z KQS.store_4.1_php54
więc całość pewnie już nowym ionCubem zakodowane. Tak samo jak Ty nie wiem wszystkiego co producent założył przy wypuszczaniu dwóch paczek aktualizacji i troszq czuję się jak dziecko we mgle ;) .
Jak będę miał nową świeżo kupioną instalkę (nie aktualizację) to przetestuję czy przy przejściu na niższy PHP niż 5.4 też wywali błąd ionCuba ... jeśli tak to można stwierdzić śmiało, że pliki z dopiskiem 5.4 są dla serwerów z uruchomionym PHP 5.4 i nowszym a producent przeszedł na nowszego ionCuba (a dla tych co jeszcze nie przeszli na nowego PHPa wypuszcza wersje ze starym ionCubem) - tak mi się przynajmniej wydaje :roll:
Avatar użytkownika
 
Posty: 329
Dołączył(a): 2009 lip 07, Wt 18:33
Lokalizacja: Lubelskie
Podziękował : 0 razy
Otrzymał podziękowań: 10 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez tofif » 2016 wrz 19, Pn 02:16

Ta dyskusja skończy się raczej przed świętami :D Zawołajcie mnie jak już coś ustalicie :lol:
Avatar użytkownika
 
Posty: 1279
Dołączył(a): 2008 kwi 28, Pn 23:03
Lokalizacja: Warszawa
Podziękował : 1 razy
Otrzymał podziękowań: 4 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez inco » 2016 wrz 29, Cz 01:54

Paczka 4.3 jest przeznaczona do aktualizacji każdego sklepu który posiada co najmniej php w wersji 5.4 (mam 5.6.4 i używam tej paczki zawsze)


paczka 4.3_5.4 do sklepów które pracują na php poniżej 5.4
 
Posty: 47
Dołączył(a): 2009 paź 22, Cz 22:04
Podziękował : 1 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez areczek » 2016 wrz 29, Cz 06:51

~herbamed ... problem w tym, że jak robiłem aktualizację z paczki 4.3_5.4 na serwerze gdzie był PHP 5.2 to mi wywaliło błąd ionCuba że wymagany PHP w wersji 5.4 więc nie bardzo ta paczka nadaje się do instalacji na serwerze z PHP mniejszym niż 5.4
Avatar użytkownika
 
Posty: 329
Dołączył(a): 2009 lip 07, Wt 18:33
Lokalizacja: Lubelskie
Podziękował : 0 razy
Otrzymał podziękowań: 10 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez inco » 2016 wrz 29, Cz 21:29

areczek napisał(a):~herbamed ... problem w tym, że jak robiłem aktualizację z paczki 4.3_5.4 na serwerze gdzie był PHP 5.2 to mi wywaliło błąd ionCuba że wymagany PHP w wersji 5.4 więc nie bardzo ta paczka nadaje się do instalacji na serwerze z PHP mniejszym niż 5.4


nie mam już tego maila ale w pewnym momencie chyba było tak że kqs wymaga minimum 5.4 i do tego zostaje ta paczka natomiast ta bez 5.4 w nazwie jest do 5.5 powyżej

co do ioncube trzeba pamiętać że jest on robiony pod konkretne wersje php wiec może być niezgodność samego ioncube z php

ogólnie to jałowa dyskusja używanie php poniżej 5.6 to dziś po prostu nieporozumienie nie sprawdzałem czy 4.3 chodzi na php 7 (4.2 nie chodził ) ale jak tylko kqs ruszy na php 7 to natychmiast się przenoszę..
 
Posty: 47
Dołączył(a): 2009 paź 22, Cz 22:04
Podziękował : 1 razy
Otrzymał podziękowań: 0 razy

Re: Aktualizacje - KQS.update_4.3 a KQS.update_4.3_php5.4

przez sucro » 2016 gru 13, Wt 17:53

dzisiaj mnie olśniło czytając wiadomość od KQS z aktualizacją. Zrozumiałem o co chodzi z tymi aktualizacjami bo za dużo kombinowaliśmy. A sprawa wygląda następująco :
Jest jedna paczka update - i jest ona do wszystkich wersji php oprócz 5.4 - pod serwer w tej wersji jest osobna paczka i jasno to KQS napisał :

Dla serwerów z PHP 5.4 została przygotowana oddzielna paczka:

czyli tylko dla serwerów php 5.4. Jak ktoś ma inną wersje php to robi update z głównego pliku aktualizacji.
Avatar użytkownika
Admin Witryny
 
Posty: 203
Dołączył(a): 2008 kwi 08, Wt 13:44
Lokalizacja: MEGAMO
Podziękował : 12 razy
Otrzymał podziękowań: 17 razy

Poprzednia stronaNastępna strona

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości
cron